Minimum disk size required for Solaris ZFS pool

Ever wanted to find out the the smallest size disk that one could use in a zfs pool? No? Well, I did (goes to show you how exciting my life really is). It turns out that your disk must be at least 64Megs in size. I started with 500Meg disks and worked my way down […]

Add ZFS file system to Solaris non-global zone

Ever wanted to add a ZFS file system to a Solaris 10 non-global zone but ran into the following error: could not verify fs /test: zfs ‘tank/test’ mountpoint is not “legacy” zoneadm: zone non-global-zone failed to verify The fix would be to update/create the ZFS dataset as a legacy mount point. For this post, I […]