Howto: Mount LOFS File System To Running Solaris 10 Zone

How to mount a loopback file system to a running Solaris 10 zone (i.e. container) from the global zone. In the example below, I’m mounting the the lofs file system as read-only so the Non-global zone cant modify the contents. Assumptions: 1. Global zone name: global 2. Non-global zone name: ngzname 3. Disk you want […]

How to grow a ZFS volume

How to grow a ZFS Volume. Assume the following is true: Pool Name: fort Volume Name: vol1 Mount Point: /mnt/vol1 1. Display file system mount status Notice its 1Gig in size (962M formatted). 2. Display current ZFS volume size and reservation properties Confirms the volume is 1Gig in size with a 1Gig reservation. 3. Change […]

Howto: Mount New File System To Running Solaris 10 Zone

I recently came across the need to mount a new file system to a Solaris 10 non-global zone without rebooting the actual zone. There are other ways to accomplish this same task but most of the solutions I’ve found required rebooting the non-global zone. Unfortunately, we could not take an outage by rebooting the non-global […]

Minimum disk size required for Solaris ZFS pool

Ever wanted to find out the the smallest size disk that one could use in a zfs pool? No? Well, I did (goes to show you how exciting my life really is). It turns out that your disk must be at least 64Megs in size. I started with 500Meg disks and worked my way down […]

Add ZFS file system to Solaris non-global zone

Ever wanted to add a ZFS file system to a Solaris 10 non-global zone but ran into the following error: could not verify fs /test: zfs ‘tank/test’ mountpoint is not “legacy” zoneadm: zone non-global-zone failed to verify The fix would be to update/create the ZFS dataset as a legacy mount point. For this post, I […]

Assign metadevice to Solaris non-global zone

From the global zone, create the SVM Metadevice like you normally would. Create the zone and add the SVM Metadevice to the zone configuration via zonecfg. global-zone# zonecfg -z myzone myzone: No such zone configured Use ‘create’ to begin configuring a new zone. zonecfg:myzone> create zonecfg:myzone> set zonepath=/zones/myzone zonecfg:myzone> set autoboot=true zonecfg:myzone> add net zonecfg:myzone:net> […]